DX11 feature level 10.0 is required to run the engine error

To start off with, please make sure that your system meets the minimum requirements to run the game. You can find out the minimum and recommended system configuration required to run the game in the link below: [What are the minimum and recommended requirements to play PUBG?]  

If the issue persists, please make sure you have the latest GPU drivers installed. Also please download the latest version of Direct X from Microsoft Download Center

Please reach out to PUBG Player Support if the issue persists.

Was this article helpful?
0 out of 26 found this helpful
Have more questions? Submit a ticket